Syntax Error: OMS Only Works During Step Through

Moderators: statman, Analyst Techy, andris, Fierce, GerineL, Smash

Dave46239
Posts: 1
Joined: Tue Mar 04, 2014 3:21 pm

Syntax Error: OMS Only Works During Step Through

Postby Dave46239 » Tue Apr 01, 2014 4:24 pm

I have a syntax file that will only run correctly when I step through the code line by line; otherwise, it errors out when I try to activate the dataset I just created with OMS. The program reports that the dataset doesn't exist, although I don't see any error reported during the OMS or OMSEND operations.

I tried commenting out the code and uncommenting it line by line, but I didn't get consistent results: sometimes it would run correctly, other times it would error out in the same place. I then reverted to a previous version of the syntax file (a known good file), and it too crashes with the same error message. I tried opening and closing SPSS, and even copied the syntax into a new syntax file.

Has anyone else experienced something like this? The syntax file ran fine yesterday, and the previous version worked all last year.

Thanks,

David

Who is online

Users browsing this forum: No registered users and 3 guests

cron