Matrix command will not run within macro

Moderators: statman, Analyst Techy, andris, Fierce, GerineL, Smash

Lakatos
Posts: 2
Joined: Thu Aug 22, 2013 4:03 pm

Matrix command will not run within macro

Postby Lakatos » Thu Aug 22, 2013 4:29 pm

Hi,
Have a matrix command section embedded in a macro.
The matrix commands run OK when not within the macro.
But they are not executed when placed within a macro.

Normally matrix programs should be alright within macros:
http://pic.dhe.ibm.com/infocenter/spsss ... _files.htm

Get error messages are like this:
Matrix
 
Run MATRIX procedure:

>Error # 12302 in column 256. Text: (End of Command)
>Syntax error.
>This command not executed.

Error in RIGHT HAND SIDE of COMPUTE command.


My purpose is to compare two matrices one of which is variable, i.e., read from different datafiles.

Any suggestions?

Have attached the syntax and the datafiles.

Many thanks in advance. (Am getting desperate...)

Zoltan
You do not have the required permissions to view the files attached to this post.
statman
Administrator
Posts: 2757
Joined: Tue Jun 12, 2007 12:08 pm
Location: Florida, USA

Re: Matrix command will not run within macro

Postby statman » Fri Aug 23, 2013 1:43 pm

Be patient, not to many matrix uses here
See the note below

NOTE: Please read the Posting Guidelines and always tell us your OS, the SPSS version and information about your study and data!

Statman
Statistical Services

Who is online

Users browsing this forum: No registered users and 1 guest

cron