Error messages for Mixed Effect Model in SPSS

Moderators: statman, Analyst Techy, andris, Fierce, GerineL, Smash

StaceF
Posts: 1
Joined: Sat Nov 18, 2017 4:19 pm

Error messages for Mixed Effect Model in SPSS

Postby StaceF » Sat Nov 18, 2017 4:26 pm

I keep getting error messages:' The levels of the repeated effect are not different for each observation within a repeated subject.' Not sure what I can't perform the LMM procedures properly.

I have two groups of participants X and Y who performed two sets of tasks i.e. A and B. Group 1 has 12 subjects, Group 2 has 16 subjects. Each subject performed 12 trials in each of the tasks although there are some missing data. I'm interested in the differences in mean latency (Dependent Variable) between the two groups and tasks (i.e. standard Mixed Plot ANOVA design) and would like to use Linear Mixed Model to analyse the data in SPSS. I labelled Task as Repeated Measures factor (same group of participants in both tasks), Group as Fixed Effect, and ID as Random Effect. I have no problems analysing Task A and Task B independently, howeverm when I place Task as the RM factor, that's when I get the error messages. I'll really appreciate if an anyone offer me some advice whether I've organised my data correctly for Mixed Effect Model in SPSS or whether it was possible to use LMM at all for my data?

I've organised my data in this manner:

ID Group Task Latency

1 A 1 283
1 A 1 357
1 A 1 457
2 A 1 289
2 A 1 354
2 A 1 892
3 B 1 283
3 B 1 357
3 B 1 457
3 B 1 289
4 B 1 354
4 B 1 892
4 B 1 283
1 A 2 283
1 A 2 357
1 A 2 457
2 A 2 289
2 A 2 354
2 A 2 892
3 B 2 283
3 B 2 357
3 B 2 457
3 B 2 289
4 B 2 354
4 B 2 892
4 B 2 283

Who is online

Users browsing this forum: No registered users and 1 guest

cron