Problem with Categorical PCA

Moderators: statman, Analyst Techy, andris, Fierce, GerineL, Smash

Torvon
Posts: 34
Joined: Sun Nov 13, 2011 8:41 pm

Problem with Categorical PCA

Postby Torvon » Tue May 08, 2012 7:20 pm

My 9 ordinal items for the CATPCA have 4 categories, 0 1 2 and 3. They are positively skewed.

Example: variable 1, frequency table:
http://www.revelation-of-silence.com/wp ... _frequ.png

When I enter them into the CATPCA, all "0" are ignored. My missing values are defined properly, and I've been using SPSS on this dataset for several months now, without problems. What could cause this?
Here the CATPCA output for the variable1:
http://www.revelation-of-silence.com/wp ... catpca.png

As you can see, 1 2 and 3 are matches, but 0 doesn't appear in CATPCA.

Thanks
-T
statman
Administrator
Posts: 2756
Joined: Tue Jun 12, 2007 12:08 pm
Location: Florida, USA

Re: Problem with Categorical PCA

Postby statman » Wed May 09, 2012 12:45 pm

See the Note below
See the note below

NOTE: Please read the Posting Guidelines and always tell us your OS, the SPSS version and information about your study and data!

Statman
Statistical Services
Torvon
Posts: 34
Joined: Sun Nov 13, 2011 8:41 pm

Re: Problem with Categorical PCA

Postby Torvon » Wed May 09, 2012 1:07 pm

A colleague of mine had the answer (he found it in some kind of documentation):

CATPCA in SPSS cannot, for a reason I don't understand, handle "0", and pretends it is missing data.

I recoded my data by
> COMPUTE y1 = y1+1
> COMPUTE y2 = y2+2
and things work now.

Hope this will show up in google and help other people with this problem.

EDIT: apologies, next time I'll post OS and SPSS version!

Who is online

Users browsing this forum: No registered users and 1 guest

cron