Problem with computing variables into an index

Moderators: statman, Analyst Techy, andris, Fierce, GerineL, Smash

peterheterjag
Posts: 5
Joined: Mon Nov 17, 2014 10:17 am

Problem with computing variables into an index

Postby peterheterjag » Mon Nov 17, 2014 10:35 am

Hi!

I am about to compute 16 recoded variables with the scale of 0-100, into one index. Like I always do I simply add all variables into the compute window and divide them with 16, after adding brackets and addition-signs. After executing the operation I check the frequancy table to control that the new index is OK. Instead of the expected frequency table I receive two tables as the one's below. No valid N. I have figured out that it is two variables that cause the problem, if I exclude them the index is properly constructed. But if I compute those two variables into index there is no problem; only when I combine them with the other 14. I'm lost. Does anyone recognize the problem and have any tip that could solve the problem?

Thanks in advance!

Best Regards,
Peter


Table 1.
Statistics
Test
N Valid 0
Missing 6289


Table 2.
Test
Frequency Percent
Missing System 6289 100,0
GerineL
Moderator
Posts: 1477
Joined: Tue Jun 10, 2008 4:50 pm

Re: Problem with computing variables into an index

Postby GerineL » Mon Nov 17, 2014 12:00 pm

have you tried running frequencies for these 2 variables separately, and looking at the variable view to see if something is going on with these variables?

Also, as an alternative to the method you described, you may want to try a different function.

instead of:
(var1 + var2 + var3 + var4) / 4

you can use:
mean(var1, var2, var3, var4)


Please post the output including error messages here.
peterheterjag
Posts: 5
Joined: Mon Nov 17, 2014 10:17 am

Re: Problem with computing variables into an index

Postby peterheterjag » Mon Nov 17, 2014 12:24 pm

I couldn't see anything strange with the variables neither in variable view nor in their frequancy table. However, when I computed the equation "mean(var1, var2...)" it somehow worked!

Thanks a lot, GerineL! :D

Regards,
Peter
GerineL
Moderator
Posts: 1477
Joined: Tue Jun 10, 2008 4:50 pm

Re: Problem with computing variables into an index

Postby GerineL » Mon Nov 17, 2014 1:13 pm

great, still curious why it didn't work the first time, but I am glad it worked out!

Who is online

Users browsing this forum: No registered users and 5 guests

cron