Could not Instantiate??

Moderators: statman, Analyst Techy, andris, Fierce, GerineL, Smash


Could not Instantiate??

Postby Hagopian » Fri Dec 12, 2008 1:20 am


Brand new copy of SPSS 17 for the MAC, worked fine at first.
Now I get the message: Could not instantiate a required server object inet: Local Computer:0.

What in heck does that mean?
And here I am about to make a presentation in India, lousy internet connection.
Posts: 2760
Joined: Tue Jun 12, 2007 12:08 pm
Location: Florida, USA

Postby statman » Fri Dec 12, 2008 5:52 pm

Sounds like a firewall issue but might be better if you contact SPSS
See the note below

NOTE: Please read the Posting Guidelines and always tell us your OS, the SPSS version and information about your study and data!

Statistical Services
Posts: 1
Joined: Sat Dec 13, 2008 12:46 am

here's the fix

Postby hagopian » Sat Dec 13, 2008 1:14 am

Okay, I had my office assistant do the call to SPSS. Here is what they said (IF YOU CAN BELIEVE IT!!!):
Hello Amy,

We have Resolution 79927 on file for this issue.

Problem Summary:
SPSS 16 or Statistics 17 on Macintosh only launches with an error 'Could not instantiate a required server object'

Resolution Summary:
The SPSS application will need to be "touched" in order to make it usable.

Resolution Description:
In order to make SPSS functional on this machine it will be necessary to "touch" the application. This means to use the touch command to update the access and modification times on the file which will allow it to launch successfully again. Here are the easiest steps to accomplish this:

1. Open up the Terminal application from 'Applications->Utilities->Terminal'.

2. Type the following command into the terminal 'touch ' without the single quotes but with the trailing space.

3. Go into the 'Applications->SPSSInc->SPSS->Statistics17 (or SPSS16)' and find the SPSS application.

4. Drag the SPSS application into the Terminal window.

5. Replace focus into the terminal window (mouse click) and then press the 'Enter' key.

After you have pressed the 'Enter' key the Terminal cursor will return to what it was before the command was entered and now SPSS should launch correctly again.

Since this process will need to be run every time the computer is started this process should be set up as a shell script and put into the users Start Up directory. These steps are detailed below:

1. In the Terminal window in step 5 highlight the touch command.

2. Go under the 'Shell' menu and select 'Export Selected Text As'.

3. Give the file some meaningful name like 'spss17touch' and be sure to show the extension of 'txt' and then change this extension to 'sh' to make the file a shell script.

4. Put this file some where you can find it (Desktop) and then move or copy this file into the folder '/local hard drive/System/Library/StartupItems' so that it can be executed at every boot of the machine.

5. Once the file has been placed into the '/local hard drive/System/Library/StartupItems' directory then the proper permissions for the file will need to be set so that it executes at every boot of the machine.

6. In the Terminal window change into the '/local hard drive/System/Library/StartupItems' directory and run the command 'ls -elf' to check the permissions on the file in the directory.

7. Now run the command 'chmod 755' and you can then re-run the 'ls -elf' command to confirm that the permissions have been changed.

Once this is done the SPSS Statistics 17 application should be functional every time the computer is booted up.

Thank You,
Posts: 1
Joined: Sat Jan 31, 2009 11:13 pm

Could not instantiate update?

Postby mfullen » Sat Jan 31, 2009 11:18 pm


I tried this fix and it still didn't work for me. I wondered if it worked for you?

Any help would be appreciated.
Posts: 1
Joined: Sun Mar 08, 2009 11:53 pm

Re: Could not Instantiate??

Postby jlwoodard » Sun Mar 08, 2009 11:59 pm

Thank you for posting this fix. It worked for me, but it was tricky to get it to work. It's important to follow the directions exactly. Can't believe we have to go through all this to get SPSS to run on the Mac.

Who is online

Users browsing this forum: No registered users and 2 guests